Htc 10 -can't attach photos and see my drives

When i try to attach photo through 'attach icon' then click 'documents' i cant see all drives i.e dropbox, media card
I can only see google drives and when i go in it doesn't let me attach photos to my whatapp message, photos are there, kinda greyed out but not selectable, pdf file can be attached.

I tried uninstall, didnt work.

This worked fine on my bb phone.

11 thoughts on “Htc 10 -can't attach photos and see my drives

  1. David

    Thats stupid if whatsapp doesnt allow you to send images this way, thats the reason i hated iOS, too inflexible and you have to do things their way.

    Also, i have to transfer files from Google drive to google photos in order to attach them.

  2. David

    Am I suppossed to be able to attach photos by attachemnt icon>document>abc drive/image?

  3. David

    Yes, i did tht and there is option to show/hide sd card, it was hidden:(, now both internal and sd card are showing

    But i still can’t attach photos tht way, no matter what drive i pick, they are greyed/unelectable, pdf are attaching ok . Can you guys attach photos via ‘document’

    And i cant see dropbox

  4. Jimmy H

    No you should see it, at least I do on Android.

    Documents -> Browse other docs… WhatsApp opens Downloads. Top left menu in downloads I see folders, Recent, Google drive and internal storage.

    You don’t?

  5. David

    In the top right in galery where 3 dots are,i can see only ‘photos’ colorful icon.
    I dont have any images in ‘photos’ folder on google drive so they wudnt show. Thats fine.

    Now, is it normal that dropbox/sd media card dont show when you select ‘document’ icon.
    Only google drives and ‘downloads’ which is i assume internal phone memory.
    I want ALL drives listed both physical and cloud drives.

  6. Anonymous

    Hi guys,

    Top right in the Gallery you see a menu with the available sources for this type of files.

    As far as I know only documents are supported for Google Drive, Dropbox, iCloud, onedrive etc. But I don’t know why…

  7. David

    Yes i can attach pix from galery but i still cant see images from google drive and dropbox.

    Seems like if i want to attach photos from google drive or dropbox i need to do it by going there, its kinda pain.

    Besides, when i do it thru dropbox it sends whole link with path,its not like normal attachment.

    I want all my locations/ drives to visible when i select document and then you drill down to whichever drive you want to and attach any file. Is that possible to achieve?

    Im sure my bb passport did tht.

  8. Jimmy H

    Ok so sharing does work and we’ve exclude permissions settings.

    I think I got you now… You’re trying to attach images via Documents. But that’s not correct and the reason that they are greyed out.

    Please try it via attach icon => Gallery (instead of documents).

    Does that solve your issue?

  9. David

    I can do it that way, by going directly to drive then open photo then send a copy but thats long way and not so convenient.
    It is annoying, bb os 10 was much better, when you select attach button it shows you all drives and locations like it should.

    Maybe whatsapp on android is not suppossed to show you all the drives/locations ?

  10. Jimmy H

    And what about going to the file first and then share file and see if whatsapp is showing up? Does that work? Or same issue?

Leave a Reply

Your email address will not be published. Required fields are marked *